Jump to content
TUFLOW Forum
tuflow support

Issue importing Stream Power grid

Recommended Posts

Q:

I have used the res_to_res utility to extract the maximum stream power from a simulation.  I have used TUFLOW_to_GIS to export the maximum stream power to an ascii grid (.asc). However, when i import this to ArcMap some of the data is skewed.  The depth and water level grids open without issue.

 

A:

We got hold of the stream power grids, which open correctly in MapInfo, but do not in ArcMap.  After some investigation the following was determined to be the cause:

 

The ascii grid is a space delimited file, in the stream power grids there were some high values.  These values are "10000.000". In the .asc grid this looks like:

1374.2073 3335.155510000.000010000.0000 9174.210910000.000010000.000010000.000010000.000010000.0000 5478.9277 2581.2310  533.0659   13.5509

 

Using the default .asc output format, there is no separator (space) between the  values (e.g. 10000.000010000.0000).  This is causing the two numbers to be treated as a single number when imported to Arc, which results in the data being skewed.  This is causing the issue when importing to Arc (but MapInfo seems to handle it).

 

In order to get around the issue there are two options:

  • Use a text editor to search and replace “10000.0000with 10000.00 .  This should fix the issue for the grids already created.
  • You can also specify the output format when using TUFLOW_to_GIS utility by using the "-prec" option.  Recreating the grids using a precision will resolve the issue.

-prec<u>.<d> sets the output precision for -asc and -mif options.  Eg: -prec12.3 would output 12 characters (or 11 if the number is negative) with 3 numbers following the decimal place.  Your batch file should like like:

tuflow_to_gis.exe -asc -t111111 -prec12.3 <filename>

 

However, these stream powers seem quite high.  These can occur as the depth goes to zero. Bed Shear Stress (BSS) and Stream Power (SP) map output can be misleading at very shallow depths as the BSS formula divides by the depth.  For the 2012-05 release of TUFLOW the BSS and SP outputs are linearly reduced to zero once the depth is below a threshold (by default, 0.1m).  To change this threshold, use “BSS Cutoff Depth == <BSS_cutoff_depth>” in the .tcf file.

 

Regards

TUFLOW Support Team

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...