Jump to content
TUFLOW Forum
O-Dogs

GPU solver prompting 1D array size error

Recommended Posts

Hi Tuflow admins

 

we are trying to run a GPU solver model. it is purely 2D. 

 

strangely the simulation prematurely exits stating:

 

Allocating 13600 Kb of temporary 1D domain memory (RAM)

Determining 1D array sizes

SORRY - 1D linking not available yet with adaptive time-stepping.

 

I have compared the setup files to another GPU solver model.

 

They are consistent with each other.

 

I can only think the error is in one of the layers?  We have checked our BC's and other layers.  We are really not sure.

 

Cheers O-Dogs

Share this post


Link to post
Share on other sites

Hi O-Dogs,

 

What I think might be the problem is a model boundary type.

At the moment, in GPU the only boundary conditions are water levels (2D HT), and source based inflows with some restrictions (ie. 2D SA, ST and RF inflows).

Until 1D links are incorporated, 2D QT or 2D HQ boundaries (which utilise a hidden 1D node) are not supported.
 
It might be worth checking that you're not using any other boundary types.
If you don't think that's the problem, send your log file over to TUFLOW support.
 
 
Cheers,
 
 
 
Rachel Jensen

Share this post


Link to post
Share on other sites

Hey Rachel, thanks, i think you have got it! i remember setting up a dummy BC HQ when i was going through the model showing some newbies.  my bad.

Share this post


Link to post
Share on other sites

Hi O-dogs,

 

If you specify a water level boundary below the ground surface the GPU applies a normal flow boundary.  You can simply specify a water level in the bc_dbase, rather than linking to time-series data.  See attached example:

 

post-220-0-66937900-1393998334_thumb.jpg

 

Cheers

Phil

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...