Jump to content
TUFLOW Forum
O-Dogs

GPU Solver unstable for pure 2D 1m grid model

Recommended Posts

Hi admins,

 

Have just been running a ~ 50ha ROG model, pure 2D domain with the GPU solver.  We really wanted to run it using 1m cells so we could pick up on small overland flow paths within the site.  the model continued to be unstable until we adopted 4m cells.

 

The 4 hour simulation ran very very fast, in about 5 minutes.  Am I right in thinking that maybe the time step may have some impact on the instability?  

 

Are there any codes that can applied to slow the time step and accept (force) a smaller grid, such as a 1m or even 2m?

 

Cheers

Share this post


Link to post
Share on other sites

Hi O-dogs,

 

What are you using as a starting timestep in the 1m model?  This is used to set the initial timestep in the GPU model and then an adaptive timestep is used.  If this is too large the model may go unstable at the very start of the model.  If the  simulation is starting ok, we have generally found the GPU module to be very stable!

 

You can lower the timestep by lowering the courant number using:

Maximum Courant Number == <Courant value, 1 is the default>

 

For example by setting the maximum Courant number to 0.8 the timestep with be reduced by 20%.

Maximum Courant Number == 0.8

 

However, we generally do not need to modify this value.  Are you able to email the log files (.tlf and .gpu.tlf) through to support@tuflow.com we can take a look at what might be occurring.

 

Cheers

Phil

Share this post


Link to post
Share on other sites

An update for other users:

 

The issues appear to be arising because no timestep has been specified in the .tcf and a default timestep of 1 second is used.  This is fine for th 4m model, but causes an issue with the 1m model. The startying timestep specified in the .tcf should be the same as you would use for a TUFLOW "classic" simulation.

 

The model is now running happily :)

 

I have mentioned this on the forum before, but if you are working with multiple cell sizes (e.g. 1, 2 and 4 ), these can be setup the as a scenario.  This allows you to easily change between the cell sizes.  This would involve you setting the cell size and timestep commands in the within an If Scenario block in your control file.

In the .tgc
!Cell size scenarios
If Scenario == 01m
     Cell Size == 1.
Else If Scenario == 02m
     Cell Size == 2.0
Else If Scenario == 04m
     Cell Size == 4.0
Else
     Pause = no cell size specified
End If


In the .tcf
!timesteps
If Scenario == 01m
     Timestep == 0.25
Else If Scenario == 02m
     Timestep == 0.5
Else If Scenario == 04m
     Timestep == 1.0
End If


When you run the model you can either have the scenario specified in the .tcf:
Model Scenarios == 01m

Or you can specify this use a batch file
Start "TUFLOW" /wait "C:\TUFLOW\Releases\2013-12\w64\TUFLOW_iSP_w64.exe" -b -s1 01m example_~s1~_001.tcf

It is recommended to use a scenario wildcard in the filename, if you run with a 01m model the results / log files will be given a unique name where ~s1~ is replaced by the scenario ( example_~s1~_001 will become example_01m_001).  If this is not used the

You can use this to run multiple scenarios easily and avoids issue like not referencing the correct .tgc!  Let me know if you want more information on this.  If you send through the .tcf and .tgc I can setup an example for you.

Tutorial module 5 introduces this:
http://wiki.tuflow.com/index.php?title=Tutorial_Module05

There is also more information on using batch files for processing multiple runs here: http://wiki.tuflow.com/index.php?title=Run_TUFLOW_From_a_Batch-file#Looping_in_a_batch_file
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...