Jump to content

Error 2024 - Tuflow Model

Recommended Posts

Hi All,


I have an ISIS-TUFLOW model I am trying to re-run which was orginally built in 2009. When trying to run it using our version of Tuflow (2013-12-AA-iDP-W64) I get the error 2024 where a 1D node is not snapped to a CN line and error 2061 where a CN connection could not be found to  the end of a HX line. I have been in to check and this is flagged for nearly all nodes and when I look they are all snapped.


Having gone back to the consultant taht built the model for us it seems they can run the model on their machines with no problem using the 2012-05-AE-isp-w32 build of Tuflow.


I have tried enetering a snap tolerance into the .tcf file but this did not work. I have also tried setting tuflow to run using the defaults from an older version of Tuflow but this still doesn't work.


Has anybody come across this before or have a workaround? The consultant doesn't think it stems with the version of Tuflow but this seems to be the only difference between what I am doing and what they are doing (it is the same model version etc)


Share this post

Link to post
Share on other sites



It is a known problem that isis/tuflow models should be run using the w32 version of tuflow. I'm not sure the reasons why but if you swap and use the 32 bit version of Tuflow it should work.



Share this post

Link to post
Share on other sites

Hi folks,


We happily use the 64bit version of ISIS with the 64bit version of TUFLOW, you just can't mix and match I think.


My quick thought on the problem at hand though (apologies if this seems a basic level of question), is that you are running this simulation from the .IEF, not trying to run the TCF are you? Because if you try to directly run a TCF from a linked model, then the problem you describe is exactly what you'll get.


Otherwise, I can't think of any reason why this should be happening to you and will await the response from WBM with interest!



Share this post

Link to post
Share on other sites

We recently had a similar problem and found that it was all as a result of the projections of the two layers being different. We were using MapInfo to generate the layers and there it is not always obvious what projection each leayer is in.
F J Maas
Senior Hydraulic Engineer
Opus International Consultants Ltd

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...