Jump to content
TUFLOW Forum
laomashu

model Pump at 1d network

Recommended Posts

Hi,

 

I am going to model pump station in 1d network with control file (TOC). I also include 1d_mh to represent the storage tank in the model. the model layout can be seen at attached pdf. 

 

the toc file is:

 

Define Pump Control == pump_op

!---------------deafult Setting ------------
Pump operation == off
Pump Capacity == 1 ! capacity in cums
Pump period (min) == 1 ! time to start
Pump number == 4 ! No of pumps

!Set user variable
H_Pump_tank == H1d Pump_tank

! operation period
if H_Pump_tank == 2 ! triger level to start pump
Pump operation == on
else if H_Pump_tank == 1.5 ! triger level to stop pump
Pump operation == off
else
Pump operation == no change
end if

End Define

 

 

my questions are:

1. dose the setting in TOC file work?

2. Can I use 2d_bc at the end of 1d pump to connect to 2d, and add u at flag attribute of sx line to prevent back flow.

 

looking for reply ASAP.

 

Regards

 

Hai Chen

Doc2.pdf

Share this post


Link to post
Share on other sites

Hi Hai,

 

In your logic control you have used equal statements:

if H_Pump_tank == 2 ! trigger level to start pump
    Pump operation == on
else if H_Pump_tank == 1.5 ! trigger level to stop pump
    Pump operation == off
else
    Pump operation == no change
end if

 

I think you want greater than / less than symbols.  E.g.

 

if H_Pump_tank > 2 ! trigger level to start pump
    Pump operation == on
else if H_Pump_tank < 1.5 ! trigger level to stop pump
    Pump operation == off
else
    Pump operation == no change
end if

 

This should trigger than pump to be on for all water levels greater than 2.

 

In terms of the connection to the 2D, yes an SX connection in the 2D BC can be used to connect the pump to the 2D, however a U flag is not required as pumps can only flow in one direction.

 

Please get back to use if this doesn't resolve the issue.

 

 

Cheers

Phil

Share this post


Link to post
Share on other sites

Hi Phil,

 

Thanks, I have changed the TOC file accordantly, however still not how to connect to 2d, , my thoughts are:

  • option 1 - use 2d_bc with one cn line and one sx line, like to connect to more than one cell
  • option2 - insert weir node in 1d_nwk file with sx at conn_1d_2d

I have tried option 2, but the result indicates the pump is not functioning. 

 

Your advise would be appreciated

 

Rgs

 

Hai

Share this post


Link to post
Share on other sites

Just an update for others.

 

Hai had determined that the issue was occurring as the name of the pump in the 1d_nwk layer was "Pump".  It would appear that the “Pump” keyword is reserved.  I’ll see if we can get a check added to give an error if this is the case.  However, changing the name of the pump to something else, e.g. "4P" allowed the model to run.

 

Cheers

Phil

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...