Jump to content
TUFLOW Forum
siripen_ace

Variable Z Shape breach won't start

Recommended Posts

I have set up a simple tidal breach model using vzshp but am unable to get a breach to start.

 

Basically, I've defined a vzshp over a defence to start a breach (invert=2mAOD) from time 0 hr and close after 72 hours, with a HT tidal boundary applied behind the defence (tide levels are greater than 2mAOD). 

 

I've also tried it with a trigger point behind the defence at the level the breach should occur (4mAOD) but it still won't open.

 

Does anyone see what's wrong here? (green - HT tidal boundary, blue - vzshp breach, grid size 10m)

post-44149-0-65878200-1421949166_thumb.j

 

Many thanks.

Share this post


Link to post
Share on other sites

I have to say that assuming a correct interpretation of what else is shown in that screen-shot, things do look like they should be working! Those attributes look good for triggering at 0 hours and maintaining the breach until 72 hours later.

So, things to check:

    That blue outline is the edge of a region, and not a line. If it's a line then it wouldn't have the effect you're looking for.
    There seem to be points snapped to the corners of the region; are those read in as part of the same command as the region? If not, then you'd need to include "NO MERGE" in the Shape_Options attribute; otherwise TUFLOW will be merging the elevations at the edge of your region with the existing zpt values at the perimeter location and using that to triangulate across the area you're trying to breach; in this particular case, from the orientation of your rectangle, that's actually going to result in the embankment being very neatly preserved.
    Is the check file from the _vzsh_zpt_check.mif? Or is it from a trial run with it read in as a normal z-shape? Depending on the answer, you might like to consider trying it as a normal z shape and see if it then does what you expect, and if not then there's something up with your points/regions/attributes. Or if it is from a zsh_zpt_check, then double check that you're referencing exactly the same files in your variable z shape command.
    This being MapInfo you're working with, if it possible that you've changed something and not yet exported it, but TUFLOW's not flagging it because you've turned off the save data check?
    You're simulation does actually encompass 0-72 hours; if your run starts at 100 hours, the trigger_value attribute does not mean the number of hours into the simulation, and you'd need to specify 100 hours for this case (although Period would remain 72).

Apologies for including some more basic things there, but sometimes it's the simple things that trip one up. If none of those get you looking in the right place, I think someone will need to see your files; sounds like a job for super support!

Hope that helps though,

PHA.

Share this post


Link to post
Share on other sites

Thank you for you suggestions PHA.

 

I've tested the vzshp file with Read GIS Z Shape to check the zpt alteration, and it seems to be doing what I expected.

post-44149-0-61867000-1422016791_thumb.j

 

Only when I read it with Read GIS Variable Z Shape (with specified trigger value at time 0hr and period of 72 hours), it doesn't seem to trigger the breach. (I can see from my PO lines across the top and the bottom of the defence that the elevations are not changed and there are no flows through it. Simulation shows no flow or breach either.)

 

My model starts running from time 0hr and the safe data check is on. 

 

Still not sure what's wrong here. Any other suggestions?

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Just to update others who may be following this thread...

 

Siripen has set the 2d_vzsh up correctly. The  _vzsh_zpt_check file confirms the start time of the breach, the period over which the zpt elevations will erode, and the final zpt elevations themselves. Another useful output for models with variable geometry is the Map Output Data Type 'ZH', This output type will show the change in elevation over time when viewed in SMS or other similar results viewer.

 

post-270-0-26362800-1422917711_thumb.jpg

Share this post


Link to post
Share on other sites

And also,

 

To reinstate the zpts, two additional attributes are required to be added to the 2d_vzsh layer with the period of the breach and the breach closure.

 

This is explained under point 26 of the 2012 release notes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...