Jump to content
TUFLOW Forum
Chapmann

Direct Rainfall on Steep Slopes

Recommended Posts

Hi All,

I’m having problems with the reporting of depths for a 2d model.

It’s a direct rainfall model with a 4m cell size. I’m running in double precision and the timestep is 0.5s.

There are steep slopes to the NE and SW of the model domain, with a less steep valley running from NW to SE through the centre.

The problem I’m having is that as soon as the rainfall is applied there are patches of flooding on the slopes which remain for the whole simulation (see attachment 1).

I have tried creating an asc for the initial flooding and then subtracting this asc from the max depth asc. The idea of this was to remove the error and be left with only the true flooding. However there are areas at the bottoms of the valley where I would expect to see flooding but I don’t (see attachment 2).

 

Does anyone know a way to fix this?

 

Thanks,

Nick

attachment 1.JPG

attachment 2.JPG

Share this post


Link to post
Share on other sites

Hi Nick,

It could be an interpolation issue to the cell corners.  There are a number of option in TUFLOW avoid this.
For example using the .tgc command “Interpolate ZUVH ALL” will set the cell side and corner elevations based on the cell centre values, ensuring the cell corner elevations are consistent.  This is processed sequentially in the .tgc and can be applied after the base DEM but before any breaklines.  E.g.
Read Grid Zpts == grid\made_up_name.flt
Interpolate ZUVH ALL
Read GIS Z Shape == gis\2d_zsh_made_up_breaklines.mif

This will ensure that the cell corner and side elevations in TUFLOW are based on the cell centres.  This can also help with mass balance if the DEM is a bit bumpy.

There are also some cell centred outputs available from TUFLOW (and more for the 2016 release), what are you using as a visualisation platform? If the model is non-rotated, you can directly write the cell centres values to GIS grid using the following:

Map Output Format == ASC
Grid Output Cell Size == 4 ! Set to the same as the cell size
Grid Output Origin == MODEL ORIGIN

Cheers

Phil

Share this post


Link to post
Share on other sites

This is a common question that we receive through support, here's a round up of our advice.

 

Q:

I am using z shapes in a direct rainfall model to lower LiDAR values by 1m using the command Read Mi Zpts ADD.

For some reason the cells around the edge of the z shape result in deeper depths. There is ponding against one side of each z shape where the lowest elevations exist but there are also wet cells around the edges of the z shape (which are not the lowest elevations). Is this something to do with the way a direct rainfall model works with z shapes?

 

A:

What’s happening to cause this:

TUFLOW is calculating the WSL at each cell ZC point like usual. Refer to the first figure below.

To output these results, TUFLOW interpolates between the ZC WSL (the red line in the second figure below) and outputs this interpolation at the ZH locations (the purple points).

This means that you can get strange interpolation results across steep areas or topography step changes.

What you can do to remedy this:

1) Output the grid formats directly through TUFLOW. 

When TUFLOW writes the grids, it outputs both the ZC and ZH points, giving you more interpolation points and potentially smoothing the interpolation. (FYI, if you has noticed that your TUFLOW grids were bigger than your post processed ones, this is why :))

 

2)    If there are still issues, provided that the model is NOT rotated, output the grid on the same dimensions as the cell size.

Map Output Format == ASC

Grid Output Cell Size == 4         ! Set to your model cell size

Grid Output Origin == MODEL ORIGIN 

This means that you will only get the ZC output

 


3)    Last option is to use the 

Interpolate ZUVH ALL

  command.
This means that TUFLOW interpolates all ZU, ZV and ZH elevations.
Caution, this will alter how your model input grid is read and could result in slightly different results.
It should sort the whole results interpolation issue, as the topography itself is interpolated.

 

 

 

 

ZC.PNG

ZH_interpolation.PNG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...