Jump to content
TUFLOW Forum
nickbartho

Overwriting 1D elements

Recommended Posts

Just trying to get a handle on any constraints with using a new 1d_nwk layer to modify an existing 1D network by overwriting only selected elements with repeat use of the Read MI Network command. The error I’m getting is “ERROR - Channel X, also occurs elsewhere in the model. Channel ID must be unique. If overwriting, channels must snap to same nodes”.

I am (I think) maintaining channel IDs and snapping to the same nodes for the copied elements. Is it also necessary to maintain the geographic location of the original nodes? Are there any other issues to be aware of that I might be overlooking?

Share this post


Link to post
Share on other sites

To overwrite an existing channel processed from a previous Read MI Network command, the new channel must have the same ID and its ends must snap to the same nodes (ie. snap to the ends of the old channel). Between the ends, the new channel polyline can have a different shape to the old one so that you can visually separate them (note that you may want to hard-wire the channel length in this case by entering a value in the Length attribute so that it doesn't use the digitised polyline length).

The new channel would be in a separate 1d_nwk layer (if it's the only change it will be the only object in that layer). Make sure the Read MI Network command for this layer occurs after the original Read MI Network command in the .ecf file.

The main thing to note is to use the check files to cross-check the override has worked. In particular, search for the Channel ID in the .eof file (using a text editor) to check that the channel properties have been overwritten properly (the .eof file contains the final 1D domain data after all processing.)

It is not necessary to maintain the same geographic location of the nodes as long as both the old and new channels remain snapped to them (usually nodes are not digitised as they are, by default, automatically created using the channel ends).

Share this post


Link to post
Share on other sites

Hi Bill & Nick

I'm trying to do this with a pipe that's connected to the next pipe downstream by an "X" channel, but I'm getting the following error

"ERROR 1243 - More than one channel snapped to start of connector - check direction of connector."

the model runs when I don't read in the layer that contains the single channel I'm overwriting, which makes me think it's not recognising that the channel is being overwritten when it's doing the check for connectors that have more than one channel upstream.  Have you had this before?

thanks

 

Sam

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...