Jump to content
TUFLOW Forum
mostlyatnight

Increasing mass error with decreasing time step

Recommended Posts

Hello all,

I am attempting to use TUFLOW to route a breach hydrograph of a small dam. The model is very simple:

20m Grid

Global roughness

ST inflows (flow divided among 14 cells)

No outflow from domain

In order to get a sensible looking plot just DS of the breach, I require a sub 1s time step.

The model seems to behave itself near the breach - however, after all inflow has stopped, the total volume in the domain keeps creeping up.

When the model is run for 10Hrs to see the destruction caused downstream - a mass balance error of +118% of the inflow volume is seen.

When the total volume in the domain is plotted, the volume continues to increase linearly with time after the inflow hydrograph has finished.

If I decrease my timestep, the line gets steeper (the problem is much more pronounced)

If I increase the timestep - the line gets very shallow.

As the problem here is occurring past the point where the complex breach flow is occurring - I am assuming that if I run a "normal" flood model with a small 2D timestep, then I will also see the same artificial increase in mass.

Any suggestions of how to get rid of this discrepancy would be much appreciated as it has not yet been possible to produce a sensible result with either the 2008 or 2007 release of TUFLOW.

Share this post


Link to post
Share on other sites

Morning mostlyatnight (I like the name)

Check that the last entry in your hydrograph is a zero, as Tuflow continues to apply the last value of the hydrograph even when you would assume that the hydrograph would have finished applying water to the model.

That may the the reason that you are getting a linear increase as time proceeds

Hope this helps

David

Share this post


Link to post
Share on other sites

An Interesting name :-)

A group of us have recently been modelling a series of dam breaches and we have come across the problems you are encountering....

firstly i recomend running in double precision in the current version of Tuflow... there are some tweaks to the default parameters in there which came from our development of breach models. I would also recomend increasing the number of itterations from the default 2 to around 10 and see if that helps your mass balance. We have had breach models running on 5m grids with default time step parameters though for larger dams we had to increase the grid size / lower the time step.

in regard to the volume increase i would checking the inflow database as suggested below...

hope this helps

Share this post


Link to post
Share on other sites

Very much sounds like a precision or non-convergence issue as per the other replies. If the suggestions provided don't help please make a copy of the model (use the -c option when running TUFLOW.exe - see Table 5.2 in the 2008 manual), zip the folder up and email to support@tuflow.com, and we'll have a quick look to see what is causing the problem. If too large to email, we can provide an ftp site to upload to.

Share this post


Link to post
Share on other sites

Hi Guy D,

Thanks for your reply and sorry for not saying so sooner - I tried the double precision version and the total volume plot now behaves how you'd expect it to.

The increase in mass seems to be a pretty much constant ammount at every time step so decreasing the TS makes it far more noticable.

Thanks again for everyone's help.

M

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...