Jump to content

Windows 7 Issues

Recommended Posts

We tried to run TUFLOW on a PC with Windows 7 for the first time from UltraEdit. The run attempted to open the TUFLOW Dongle XXXX Simulations.log file but it did not exist (first time run). It then tried to create the file. However, it would appear that Windows 7 needs administrator rights to create a file direclty onto the C drive.

We overcame it by creating the file manually (as administrator). Anybody had similar problems ?

Share this post

Link to post
Share on other sites

G'day Greg,

You can also overcome administrator privilege issues by changing the directory that TUFLOW writes the simulations log to. This can be done by running TUFLOW with the -slp switch.


TUFLOW.exe -slp “<url_path_to_global_log_file>”.

This can be a local directory which you do have rights to or a network drive

For more info see:




Share this post

Link to post
Share on other sites

I am running TUFLOW through SMS on a Windows 7 PC and had the same error message. Even though I am the administrator of the PC, I had to change the SMS properties to run the program as an administrator. (Right-click on the desktop icon, select Properties, select Compatibility tab, and toggle "Run this program as administrator" under the Priviledge Level.)

My IT personnel said that there are some additional levels of security in the Vista/Windows 7 Operating Systems which generate these errors when programs inside another program try to write to the C drive.

Good luck!

Share this post

Link to post
Share on other sites

.mat files in Windows7


We have found that trying to open a TUFLOW results folder that contains the .mat file crashes explorer under Windows7. There was no way to work around this, as the folder couldn't be opened to edit/remove the file & the File Association program in the Control Panel also crashes.

A quick bit of internet research and apparently this is a common problem: .mat files crash windows explorer.

This may be related to Microsoft Access installing a faulty dll handler for this file type. If you can change the file association you can fix this problem!

This problem will no doubt be addressed in a windows update at some stage. However for the present, . . .

A strange workaround:


I found that while others in the office were having this problem, my computer was fine. The answer was that I had installed Winamp (www.winamp.com), as the default media player, and it was associated with .mat media files.

While maybe not the best way to solve this problem, installing Winamp will fix this problem and stop explorer from crashing.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...