Jump to content
TUFLOW Forum
dannyduong

pBlockage for C culverts

Recommended Posts

Hi there,

I am attempting to model some pipes (C channel) with 75% blockage.

From table 4.12 of the 2008 manual, the pBlockage is described as:

C, I, R Channel Type:

After Build 2003-06-AD, the % blockage (for 10%, enter 10). For R culverts, the culvert width is reduced by the % Blockage, while for C culverts the pipe diameter is reduced by the square root of the % Blockage.

So exactly do I input a number to achieve 75% blockage?

As far as I can understand that wording, it looks like using 75 (for 75%) reduces the pipe diameter by 8.66 units.

Can someone please clarify?

Regards,

Danny

Share this post


Link to post
Share on other sites

Hi Danny,

You should specify "75" in the pBlockage attribute to signify a 75% blockage.

I think the wording should read that the pipe diameter is reduced by the square root of (1 - B ), where B is blockage as a proportion. i.e. in this case, the radius would be reduced by sqrt(1-0.75) = 0.5.

You can double check that the pipe area in your blockage run is 1/4 of the pipe area in the free flowing run by looking at the area of the pipe, listed under "channel properties at top of section" in the .eof files.

I've confused myself with algebra now, I hope I've got that right!

Cheers

Richard

Share this post


Link to post
Share on other sites

You should specify "75" in the pBlockage attribute to signify a 75% blockage.

I think the wording should read that the pipe diameter is reduced by the square root of (1 - B ), where B is blockage as a proportion. i.e. in this case, the radius would be reduced by sqrt(1-0.75) = 0.5.

Hi Richard,

Thanks for the tips. Your explanation of the reduction in pipe diameter makes so much more sense!

I'll try and run the TUFLOW model with those values and see how it goes.

I really think the manual should be updated with an explanation similar to yours.

Thanks again.

Danny

Share this post


Link to post
Share on other sites

Now there's a related matter, and I might as well ask this in here.

I've run the model and taken a look at the TS (time series) output file for the 1D pipe I have blocked using pBlockage set to 100. There is no flow "q" which is quite correct, but there is velocity.

Is that correct? I had the impression that for blocking a pipe, neither flow nor velocity could exist.

Thanks.

Danny

Share this post


Link to post
Share on other sites

I think Tuflow probably needs a non-zero area for it's calculations, and so there will be a very small amount of flow. I've seen a similar occurrence when using a 100% blockage - the .eof shows an area of 0.02 for the culvert, velocity is around 0.5m/s and flow is 0.008m3/s.

In my case it didn't significantly affect results, but I guess if you really needed absolutely zero flow you could always remove the culvert completely...

Cheers

Richard

Share this post


Link to post
Share on other sites

It just seems strange to have both no area and no flow but a velocity present.

I'm trying to run a sensitivity analysis by blocking off a reasonably large number of pipes, not necessarily at 100% blockage. It would be interesting to see how significant the results would be affected if the "errors" started to accumulate.

Based on your experimenting though, it appears that the additional flow isn't too significant.

Cheers

Danny

Share this post


Link to post
Share on other sites

Hi Danny,

If you want to completely block the pipe (ie zero flow and velocity) but don't want to delete it from the 1d network, you could try setting the pipes "Ignore" attribute to T.

Cheers,

Mick

Share this post


Link to post
Share on other sites

Hi Mick,

That was my original intention. I just thought it would be more useful if I manipulated "pBlockage" instead.

So as far as I can see, "pBlockage" is useful from 0 to 99% and "Ignore" is useful for 100% blockage.

Cheers,

Danny

Share this post


Link to post
Share on other sites

Hi Danny

Yes, you can't have a zero area (otherwise a divide by zero occurs), hence 100% blockage will end up something like 99.9% (area can't be below 0.001m2 from memory), and a very small flow (usually negligible) will result. If you really need to block it off entirely, using the Ignore attribute or changing the inverts to above the highest flood level are the easiest ways.

A good tip when modifying your 1D network like this is that you can use additional 1d_nwk layers to change channels in the same manner as with 2D Zpts. For example, if you have one or more culverts to change, select the culverts and save the selection as a new 1d_nwk layer (ie. this layer only has the culverts in it), make the changes to blockage, inverts, sizes, etc and then add a "Read MI Network" line that reads the culverts in after the main "Read MI Network" 1d_nwk layer in the .ecf file. Any channel in a subsequent layer that has the same ID and is snapped to the same nodes will override any previous channels of the same ID. Check the _messages.mif and 1d_nwk_check.mif layers and also the .eof file to make sure the channels have changed as you wanted them to. The advantage of using this approach is that you don't have to copy all of the unchanged channels each time you want to make a change.

Cheers

Bill

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...