Jump to content
TUFLOW Forum
tuflow support

WARNING 2365 - Exceeded top of HQ curve.

Recommended Posts

Q:

I am using an automatically created HQ boundary, however during the simulation I repeatedly get the following warning:

WARNING 2365 - Exceeded top of HQ curve. Water Level = <value>

I am using separate HQ boundaries for the main channel and the adjacent floodplain. The water level will exceed the top of bank of the main channel, is there a way to extend this upward?

A:

Yes, you can use the 2d_bc “d” attribute to set the maximum depth of the automatically generated HQ curve (note d is a depth, not an elevation). In the example below there are two HQ curves (check in the _2d_bc_tables_check.csv) one without a d attribute, and the other with a d (depth) attribute of 8.

post-219-0-97006300-1314846318_thumb.jpg

Share this post


Link to post
Share on other sites

 Some further information on this topic, as it's a question that is often asked:

 

TUFLOW reports this error if the water surface level at your boundary exceeds the highest cell elevation at your boundary.

The HQ boundary automatically creates an stage-discharge relationship to the highest elevation encountered along the boundary.

In the first figure below I’ve drawn an example HQ boundary in section with the boundary shown in red.

 

There are two ways that you can address this warning:

1.       You can use the ‘d’ flag in the attribute column of the 2d_bc layer.

Refer to figure 2

This ‘d’ is the total depth that you’ll allow above the HQ boundary. What this does is set glass walls either side of the boundary and allows you to extend the depth up to a maximum of ‘d’ metres. See the figure below.

If you want to use this method, work out the depth of the maximum water surface level above your boundary and set your ‘d’ value at or above that.

Something to be careful of here is that the glass walls you add in do not take into account the increase in floodplain storage as the water surface level goes up.  (shown in yellow). This might artificially inflate your water surface levels immediately downstream and understate your extent.

 

2.       Extend your HQ boundary.

Refer to figure 3.

This way the highest cell HQ boundary cell elevation should be above the water surface level. This is the preferred solution because it doesn’t rely on ‘glass walling’ flow through the boundary. Note that results will be a little difference immediately downstream of the boundary. 

post-54099-0-61883100-1432533744_thumb.j

post-54099-0-40275400-1432533750_thumb.j

post-54099-0-12203900-1432533756_thumb.j

Share this post


Link to post
Share on other sites

Hi Rachael and Support,

As a follow up question; what does TUFLOW do in the event that the depth of the boundary is exceeded? Does the outflow get limited to that at the limit of the discharge curve, and water back up behind the boundary, or does TUFLOW just set the level in the cells to be that at the limit of the discharge, and remove more water from the model? Or something else?! I would have thought one of those options, but from looking at some model results which report this warning, the limit of the data is 6.5mAOD, but the max water surface next to the boundary is only 6.45, which is not what I was expecting. Some clarification would be appreciated.

Either way, I'm probably going to be recommending adding a 'd' value in the case of this project, but it would be nice to know. :)

Thanks,

PHA.

Share this post


Link to post
Share on other sites

Hi PHA,

Good question

The outflow is limited to the maximum value of that HQ curve. If the water level stays above the curve, Tuflow will continue to remove the maximum Q specified but the water surface will back up behind the boundary. This obviously has a marked effect on your model results so I'm of the opinion that's why the error persistently reoccurs and is very obvious in your tlf!

In the case of your boundary, and perhaps you've already looked at these things, I'd have a look in your 2D tables check file to see exactly what curve Tuflow is using and check that upper limit. If you think the boundary is still behaving oddly, you're welcome to send through your WSL grid, boundary layer and 2D table check for us to investigate.

Either way, if you're getting that error your totally right that a 'd' value or reconfiguration of the line is the way to go :)

Cheers,

 

 

 

Rachel

Share this post


Link to post
Share on other sites

Hi Rachel and Support,

I've had an issue with the following a couple of times.

I receive the 'WARNING 2365 - Exceeded top of HQ curve.' and so I either extend my HQ boundary line or use the ‘d’ flag in the attribute column of the 2d_bc layer.

In some cases this works fine. In others, I still receive the warning, but still runs through the simulation to the end. However, when I bring in my results file, the flood levels are concentrated along the QT boundary line.

I suspected it might be to do with the way I merged the ascii files, and so tried merging them in different ways. I have also tried to use 1m grids instead of 2m grids. But with no success. I also adjusted the cell size/time step, and adjusted the 2d_bc layer and 2d_code layer, but to no avail.

Any ideas on why this happens?

Thanks in advance

Tom

Share this post


Link to post
Share on other sites

Hi Tom,

Without knowing much about the setup of your model I would be inclined to run through the following checks first;

  • Open your BC tables check file and ensure that you have a sensible stage-discharge relationship at your boundary;
  • Generate a terrain cross section along your HQ boundary. HQ boundaries are typically used for defined channels as they work by applying a constant water level along the whole boundary based on the incoming flow. If you have undulating terrain along the boundary the water level will most likely be different, especially for long HQ boundaries, and TUFLOW is trying to apply a constant level to the boundary line which can cause issues; and 
  • View a time series of your 2D results at the boundary and check for circulations.  

I suspect the issue has to do with your HQ boundary setup.

Cheers,

Rohan

Share this post


Link to post
Share on other sites

Hi Tom.

I'm just noticing you say that this is concentrated along your QT boundary, not the HQ. Is that correct? On the basis it is... I assume that a QT has to establish its own stage discharge relationship, based on the underlying cells (in the same way as an HQ does) and if you are putting 'too much' flow into the model then that stage/discharge relationship could be exceeded and TUFLOW won't know what to do. I'd guess there's no equivalent 'd' value here, so your best bet would be to extend your QT boundary further.

If "QT" in your post was just a slip of the finger, then hopefully the Riders of Rohan's suggestions will see you right. :)

Please let us know how you get on,

PHA.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...